Правила     Закладки     Карма    Календарь    Журналы    Помощь    Поиск    PDA    Чат   
        СМС-ки
   
Пейджер выключен!
 
Фильтр авторов:    показать 
  скрыть
  Ответ в темуСоздание новой темыСоздание опроса

> Точка входа в процедуру не найдена в php5.dll
elestrado  
 ۩  Дата
Цитировать сообщение

Пользователя сейчас нет на форуме



Новичок
*

Профиль
Группа: Пользователь
Сообщений: 7
Пользователь №: 38867
На форуме: 2 года, 9 месяцев, 26 дней
Карма:




Всем здравствуйте. Проблема: на WinServ 2008 r2+IIS7+MSQSQL2008 стоял php 5.3. Решил обновить версию php на 5.5.30, но автоматом с помощью web installer не встал. Поставил вручную, драйвера подключил, в IIS все прописал, подключил php5.5.30 к одному из сайтов (moodle), вроде все показало в phpinfo, вроде все работает. Но в логах довольно много ошибок, да и решил cron запустить через консоль и получил вот это (прикрепил). В чем может быть проблема? Библиотек таких не нашел, в php.ini такого ничего не прописано
user posted image
PMПисьмо на e-mail пользователю
    0   Для быстрого поиска похожих сообщений выделите 1-2 слова в тексте и нажмите сюда Для быстрой цитаты из этого сообщения выделите текст и нажмите сюда
redreem  
Дата
Цитировать сообщение

Пользователя сейчас нет на форуме



Здесь живет
******

Профиль
Группа: Форумчанин
Завсегдатай форума
Сообщений: 4258
Пользователь №: 29002
На форуме: 5 лет, 4 месяца, 7 дней
Карма: 147




дык черным по-русски написано: "нет процедурый такой в этой дллке".
скорее всего php5.dll от другой версии. вариант - сделать поиск всех php5.dll и заменить на нужную библиотеку. возможно есть несколько таких файлов из разных версий и винда дергает не ту библиотеку.
PMПисьмо на e-mail пользователю
    0   Для быстрого поиска похожих сообщений выделите 1-2 слова в тексте и нажмите сюда Для быстрой цитаты из этого сообщения выделите текст и нажмите сюда
elestrado  
 ۩  Дата
Цитировать сообщение

Пользователя сейчас нет на форуме



Новичок
*

Профиль
Группа: Пользователь
Сообщений: 7
Пользователь №: 38867
На форуме: 2 года, 9 месяцев, 26 дней
Карма:




Цитата (redreem @ 21.03.2016 - 14:12)
заменить на нужную библиотеку

есть еще версия 5.3 и в ней я так понял свой php5.dll. На нем работают несколько сайтов. 5.5 стоит только для одного сайта и файл php5.dll там свой.
Я так понял мне из 5.5 скопировать файл php5.dll в 5.3? Конфликтов не будет с другими сайтами на 5.3?
PMПисьмо на e-mail пользователю
    0   Для быстрого поиска похожих сообщений выделите 1-2 слова в тексте и нажмите сюда Для быстрой цитаты из этого сообщения выделите текст и нажмите сюда
redreem  
Дата
Цитировать сообщение

Пользователя сейчас нет на форуме



Здесь живет
******

Профиль
Группа: Форумчанин
Завсегдатай форума
Сообщений: 4258
Пользователь №: 29002
На форуме: 5 лет, 4 месяца, 7 дней
Карма: 147




вопрос в том, почему крон гребет этот файл из 5.3. смотреть надо настройки всякие. ну или как минимум попробуй копирнуть (сохранив естественно старый файл где-нибудь) и посмотреть что получится.
PMПисьмо на e-mail пользователю
    0   Для быстрого поиска похожих сообщений выделите 1-2 слова в тексте и нажмите сюда Для быстрой цитаты из этого сообщения выделите текст и нажмите сюда
  Быстрый ответ
Информация о Госте
Введите Ваше имя
Кнопки кодов
Для вставки цитаты, выделите нужный текст и
НАЖМИТЕ СЮДА
Введите сообщение
Смайлики
:huh:  :o  ;) 
:P  :D  :lol: 
B)  :rolleyes:  <_< 
:)  :angry:  :( 
:unsure:  :blink:  :ph34r: 
     
Показать всё

Опции сообщения  Включить смайлики?
 Включить подпись?
 
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:

Опции темы Ответ в темуСоздание новой темыСоздание опроса