Правила     Закладки     Карма    Календарь    Журналы    Помощь    Поиск    PDA    Чат   
        СМС-ки
   
Пейджер выключен!
 
Фильтр авторов:    показать 
  скрыть
  Закрытая темаСоздание новой темыСоздание опроса

> Не работает mysql_connect в bash
skater4  
 ۩  [x] Дата
Цитировать сообщение

Пользователя сейчас нет на форуме



Новичок
*

Профиль
Группа: Пользователь
Сообщений: 45
Пользователь №: 30333
На форуме: 5 лет, 8 месяцев, 21 день
Карма: -1




Всем привет. при запуске php файла в командной строке на хостинге ему не нравится функция mysql_connect. точнее он ее не видит, выдает, что undefined.
в php -m модуля mysql не видно, хотя

extension_dir="/opt/php/lib/php/extensions/"
extension=timezonedb.so
extension=curl.so
extension=dba.so
extension=dbase.so
extension=dom.so
extension=gd_ext.so
extension=iconv.so
extension=imap.so
extension=mysql.so
extension=mysqli.so
extension=sqlite.so
extension=pgsql.so
extension=pdo.so
extension=pdo_mysql.so
extension=pdo_sqlite.so
extension=pdo_pgsql.so
extension=xsl.so
extension=zlib.so
extension=templates.so
extension=json.so
extension=session.so

тут он есть. подскажите пожалуйста, в чем проблема



Спустя 3 дня, 22 часа, 25 минут, 13 секунд (2.05.2012 - 07:35) skater4 написал(а):
Сори что пишу не туда, но в нужной теме никто не отвечает уже несколько дней.
Всем привет. при запуске php файла в командной строке на хостинге ему не нравится функция mysql_connect. точнее он ее не видит, выдает, что undefined.
в php -m модуля mysql не видно, хотя

extension_dir="/opt/php/lib/php/extensions/"
extension=timezonedb.so
extension=curl.so
extension=dba.so
extension=dbase.so
extension=dom.so
extension=gd_ext.so
extension=iconv.so
extension=imap.so
extension=mysql.so
extension=mysqli.so
extension=sqlite.so
extension=pgsql.so
extension=pdo.so
extension=pdo_mysql.so
extension=pdo_sqlite.so
extension=pdo_pgsql.so
extension=xsl.so
extension=zlib.so
extension=templates.so
extension=json.so
extension=session.so

тут он есть. подскажите пожалуйста, в чем проблема

Спустя 26 минут, 10 секунд (2.05.2012 - 08:01) stasuss написал(а):
возможно потому что для коммандной строки отдельный файл настроек?

Спустя 6 минут, 44 секунды (2.05.2012 - 08:07) Oyeme написал(а):

extension=pdo.so
extension=pdo_mysql.so
extension=pdo_sqlite.so
extension=pdo_pgsql.so


http://php.net/manual/en/book.pdo.php

Спустя 6 минут, 36 секунд (2.05.2012 - 08:14) Invis1ble написал(а):

 ! 

М
Не создавай дубли!
Invis1ble

Спустя 1 минута, 51 секунда (2.05.2012 - 08:16) Invis1ble написал(а):
По теме - для окружения CLI имеется отдельный php.ini



Спустя 25 минут, 55 секунд Invis1ble написал(а):
и еще: неплохо было бы уточнить версию php

Спустя 47 минут, 11 секунд (2.05.2012 - 09:03) skater4 написал(а):
версия 5.2.10, а где находится этот файл настроек?

Спустя 9 минут, 3 секунды (2.05.2012 - 09:12) Invis1ble написал(а):
skater4
у меня например в /etc/php5/cli/ , у тебя не знаю

Спустя 18 минут, 33 секунды (2.05.2012 - 09:31) killer8080 написал(а):
skater4
выполни в консоли команду
php -r  "phpinfo();" | grep php.ini

увидишь какой ini файл используется в cli, у меня в дебиане так
Loaded Configuration File => /etc/php5/cli/php.ini

Спустя 11 минут, 5 секунд (2.05.2012 - 09:42) Guest написал(а):
выдает /opt/php/lib, но там только папки build и extensions

Спустя 21 минута, 20 секунд (2.05.2012 - 10:03) killer8080 написал(а):
Цитата (Guest @ 2.05.2012 - 10:42)
выдает /opt/php/lib, но там только папки build и extensions

Вот поэтому ничего и не работает.
Попробуй скопировать туда основной ini файл. Возможно придется его подправить. Отличия настроек для CLI смотри здесь

Спустя 6 минут, 21 секунда (2.05.2012 - 10:09) Guest написал(а):
ха, а туда закачивать ничего нельзя)доступа нет)

Спустя 6 минут, 26 секунд (2.05.2012 - 10:16) killer8080 написал(а):
Цитата (Guest @ 2.05.2012 - 11:09)
ха, а туда закачивать ничего нельзя)доступа нет)

Хостинг какой? VPS или шаред? Если шаред, обращайся в суппорт хостера, пускай восстанавливают php.ini для CLI режима.

Спустя 1 минута, 14 секунд (2.05.2012 - 10:17) Invis1ble написал(а):
а я б независимо от теребил саппорт

Спустя 1 день, 21 час, 7 минут, 16 секунд (4.05.2012 - 07:24) skater4 написал(а):
так и надо было)оказывается там надо прям с командой запуска php скрипта подключать файл php.ini)

Спустя 4 часа, 28 минут, 51 секунда (4.05.2012 - 11:53) killer8080 написал(а):
Цитата (skater4 @ 4.05.2012 - 08:24)
так и надо было)оказывается там надо прям с командой запуска php скрипта подключать файл php.ini)

Ну да, а ничего что конфигурация для CLI отличается от CGI, потому и нужен отдельный ini файл?
То есть админы тупо отмазались, вместо того чтобы решать проблему. smile.gif
PMПисьмо на e-mail пользователю
    0   Для быстрого поиска похожих сообщений выделите 1-2 слова в тексте и нажмите сюда Для быстрой цитаты из этого сообщения выделите текст и нажмите сюда
1 Пользователей читают эту тему (1 Гостей и 0 Скрытых Пользователей)
0 Пользователей:

Опции темы Закрытая темаСоздание новой темыСоздание опроса